Slowness in invitation delivery (SMS & email)
Incident Report for Surveypal
Resolved
The issue with invitation delivery delays has now been fixed and at the same time we have also improved delivery handling. During the time this issue was live, we experienced only couple of events where we saw longer than expected delivery times. We apologise for the inconvenience this issue may have caused.
Posted May 11, 2023 - 16:37 EEST
Identified
We have identified an issue in email and sms invitations that causes noticeable delays in their delivery. We are looking into solutions to mitigate this. We apologise for the inconvenience this causes!
Posted Mar 27, 2023 - 15:14 EEST
This incident affected: Survey invitations (SMS & emails).