Issue in responding to surveys
Incident Report for Surveypal
Resolved
This incident has been resolved.
Posted Sep 05, 2022 - 22:38 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2022 - 19:03 EEST
Identified
We have identified an issue causing respondents to see an error when trying to submit their survey response. A fix is being implemented.
Posted Sep 05, 2022 - 18:16 EEST
This incident affected: Surveys.