Login issues
Incident Report for Surveypal
Resolved
The incident has been resolved. The issue was related to a recent infrastructure update which impacted only Surveypal service users. Response collection worked normally. We apologise for the inconvenience this issue caused!
Posted Apr 27, 2023 - 10:13 EEST
Monitoring
The issue has been resolved. We are monitoring the situation.
Posted Apr 27, 2023 - 08:53 EEST
Investigating
We currently investigating the issue with service login. We apologise the for the inconvenience this issue causes!
Posted Apr 27, 2023 - 08:40 EEST
This incident affected: Application.