Partial failure to trigger automation with on submitted condition

Incident Report for Surveypal

Postmortem

Incident summary

On 10.4. klo 10:00, a production release was deployed but only partially applied. Because part of the infrastructure continued running an older version, automations for submitted events did not trigger correctly.

The issue was fixed on 13.4. klo 15:00, and missed automations were reprocessed for the affected answers.

Customer impact

Some customers experienced missing automation triggers after submitting answers. The issue affected only the part of the system that remained on the older version.

Root cause

The production release did not complete successfully across all infrastructure components. This left part of the environment running outdated code, which caused the automation logic to behave unexpectedly.

Resolution

The deployment issue was corrected on 13.4. After the fix, missed automations were triggered again for affected answers.

What we are improving

To reduce the risk of this happening again, we are focusing on:

  • stronger checks that confirm all components are running the intended version.

Status

The incident is resolved.

Posted Apr 13, 2026 - 16:43 EEST

Resolved

On 10.4 at 10:00, a production release was deployed but only partially took effect. An unnoticed delivery failure caused part of the infrastructure to continue running the old code. As a result, automations for submitted events did not always trigger correctly because the expected conditions were not met.

The release was fixed on 13.4 at around 15:00, and the missed automations were triggered again for the affected answers.
Posted Apr 10, 2026 - 10:00 EEST