Issue with survey previews
Incident Report for Surveypal
Resolved
A survey technology performance update on Tuesday afternoon 16th of May broke survey preview links. The issue was fixed in the afternoon of May 17th. We apologise for the inconvenience this caused!
Posted May 16, 2023 - 19:52 EEST