Public result viewing links direct to login page
Incident Report for Surveypal
Resolved
The issue was resolved on Thursday morning 21st of May. Apologies for the inconvenience!
Posted May 22, 2020 - 11:12 EEST
Identified
We have identified the issue as regression from service update done this morning. A fix is being prepared.
Posted May 20, 2020 - 11:00 EEST
Investigating
We are investigating this issue.
Posted May 20, 2020 - 10:27 EEST